Browser Recommendations

What browsers are recommended for use with Blackboard, and where can I download them?

We recommend the following browsers for use with Blackboard:

We strongly recommend that Macintosh users upgrade their system to X.3 or later.

IE for Macintosh is not supported and will not work with Blackboard. Also see our separate FAQ entry for configuring IE 7.0 for Blackboard.

Chrome 10.0 and Firefox 4.0 were the latest available versions at the time of testing, and Blackbaord is supporting all newer stable versions of Chrome and Firefox.

Click here to test whether your browser is compatible with Blackboard.