Skip to main content

New to Dartmouth?

Resources for:

Information Security

Connect with Computing

facebook twitter Wordpress Blog
Home >   Computing Help

Internet Explorer Vulnerability

A security vulnerability was recently discovered affecting all versions of Internet Explorer. This vulnerability allows others to take control of your computer without your knowledge.

On May 1st, Microsoft released an update fixing this vulnerability for all versions of Windows (including XP). It is critical that all users run Windows Update on their computer as soon as possible to fix this vulnerability. If you are unsure of how to run Windows Update, contact your school's IT support Office, email help@dartmouth.edu or call 603-646-2999.

Last Updated: 5/2/14